MongoDB (3.2) no se inicia en Lubuntu 16.04 LTS como servicio


26

Por alguna razón, cada vez que intento iniciar MongoDB como un servicio ( sudo service mongod start) obtengo el siguiente error:

Failed to start mongod.service: Unit mongod.service not found.

Seguí la guía de instalación en el sitio MongoDB.

Respuestas:


58

Las instrucciones / paquetes en el sitio MongoDB están actualmente disponibles solo para LTS Ubuntu 12.04 y 14.04. Los paquetes están configurados para usar upstart en lugar de systemd. Debe crear un archivo systemctl para estar listo para systemd. Créalo por

sudo nano /etc/systemd/system/mongodb.service

Se verá como

[Unit]
Description=High-performance, schema-free document-oriented database
After=network.target

[Service]
User=mongodb
ExecStart=/usr/bin/mongod --quiet --config /etc/mongod.conf

[Install]
WantedBy=multi-user.target

Ahora puede iniciar el servicio y verificar su estado

sudo systemctl start mongodb
sudo systemctl status mongodb

y finalmente habilitarlo permanentemente

sudo systemctl enable mongodb

(Fuente: Cómo instalar MongoDB en Ubuntu 16.04 )


A veces no se inicia por un error de RED. En tal caso, intente eliminar el archivo de calcetines en / tmp
— Nidhin David

La forma oficial de hacerlo es usar mongod para el nombre del servicio
— Luca Steeb

44
Seguí estas instrucciones e intenté ejecutar sudo systemctl start mongodb, pero recibí el siguiente mensaje de error: "Error al iniciar mongodb.service: la unidad mongodb.service está enmascarada". Ejecutar "sudo systemctl unmask mongodb" solucionó el error
— Robert Townley

acabas de salvarme el día
— Rahul Kumar

Gracias un registro JeffRSon, me salvó el día, estaba luchando para que esto funcionara.
— Pionero el

5

Simplemente ejecute sudo mongodpara iniciar el demonio y luego sudo mongopara acceder al shell


10
¿Siempre ejecuta bases de datos en sus servidores de esta manera?
— ruX

lamentablemente esto funcionó para mí ... Así que necesitaba cambiar los permisos para el usuario de mongo
— Jamie Hutber

esto funcionó para mí, pero también necesitaba cd /, luego sudo mkdir data y luego sudo mkdir / data / db.
— edencorbin

0

Ejecutar el siguiente comando funcionó para mí. Ejecute mongo con el archivo de configuración.
Solo corre mongod --config /etc/mongod.conf.


1
esta opción se elimina en mongo 3.6.6
— vijay
Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.