Sudo no funciona: "/ etc / sudoers es propiedad de uid 1000, debería ser 0"


21

Cuando escriba el comando sudo por Terminal y luego muestre el error, Cómo solucionar esto

sudo: /etc/sudoers is owned by uid 1000, should be 0
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

Respuestas:


31

Vuelva a cambiar el propietario a root:

pkexec chown root:root /etc/sudoers /etc/sudoers.d -R

O utilice el visudocomando para garantizar la corrección general de los archivos (gracias a @KasiyA ):

pkexec visudo

3
La forma más fácil de solucionarlo es:pkexec visudo
— αғsнιη

Estoy teniendo un problema, tengo una instancia ec2 y probé su solución y me pide una contraseña. ¿Cómo mitigar esto?
— David

Bueno, eso apesta; "El programa 'pkexec' no está instalado actualmente. Puede instalarlo escribiendo: sudo apt-get install policykit-1"
— Koen.

@Koen. Se instala por defecto en Ubuntu (a menos que esté hablando de un servidor o una instalación mínima, tal vez).
— muru

De hecho, una instalación de servidor, pero lo arreglé arrancando en modo de usuario único.
— Koen
Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.