Exim PanicLog tiene un tamaño distinto de cero ...?


14

Recibo el siguiente error de mi servidor Ubuntu:

exim paniclog /var/log/exim4/paniclog on (my server FQDN) has non-zero size, mail system might be broken.

Encontré una solución en la web aquí . Básicamente, solo necesito borrar el paniclog ingresando el siguiente código:

sudo rm /var/log/exim4/paniclog

Entonces, sé cómo deshacerme del error, pero no sé cómo comenzó y cómo no permitir que vuelva a suceder. Alguna explicación? Gracias por adelantado.


2
Publique el contenido de paniclog para ver el error específico que exim está generando, y luego podemos aconsejarle sobre cómo evitar que el error vuelva a ocurrir. Exim sólo está haciendo su trabajo y que le dice que algo inesperado sucedió :)
— roadmr

Esta pregunta parece estar abandonada y sin respuesta, ¿podría agregar más detalles a su pregunta? Si esta pregunta ya no se aplica, puede eliminarla o responderla usted mismo si ha resuelto el problema. ¡Gracias!
— Kevin Bowen

Respuestas:


5

Tuve el mismo problema, así es como se veía mi exim4 paniclog:

$ sudo cat /var/log/exim4/paniclog

2014-02-01 21:36:51 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:03:33 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:33:19 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:36:33 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 23:03:51 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 23:14:31 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-02 11:09:48 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned

Aparentemente, este problema se resolvió eliminando el archivo paniclog


55
No No se resuelve eliminando ese archivo.
— Olli

¿Qué tiene que ver una dirección ocupada con un archivo de registro? @willbeeler comprueba qué aplicación usa el puerto 25
— s3lph

Esta es la solución si el problema fue temporal y los mensajes del archivo de registro ya no se aplican. Elimine el registro para dejar de recibir estas advertencias de pánico.
— Eric Woodruff

Los registros siempre son buenos
— Stevie G

sí funcionó ... reiniciar exim después de eliminar
— Abhishek Goel

2

Esta entrada de blog parece tener una respuesta. Parece que puede tener que ver con la configuración de IPv6 y los resultados de un cambio en la forma en que el núcleo admite IPv6.

Básicamente, deshabilite IPv6 por ahora.


1
Si bien esto puede responder teóricamente la pregunta, sería preferible incluir aquí las partes esenciales de la respuesta y proporcionar el enlace para referencia.
— Kevin Bowen

55
Y ahora tenemos el razonamiento detrás del comentario de @KevinBowen. Su enlace está muerto y ahora su respuesta no tiene sentido sin él. Resuma y extraiga la información relevante de todos los enlaces
— Sirenas

Mi suposición en ese momento y aún es que deshabilitar IPv6 es una solución temporal. Desactivar IPv6 nunca debería convertirse en una solución estándar, por lo que esta respuesta debería ser inútil más de 5 años a pesar de la razón por la que se hizo.
— flickerfly

0

En mi caso, faltaba el archivo passwd, lo que causaba que exim4 entrara en pánico. Agregué un nuevo usuario, y eso agregó el archivo, con los permisos adecuados, y el contenido exim espera estar allí.

Parece que exim necesita al menos un usuario local, y ese dominio tenía todos los usuarios de reenvío. Una vez que agregué un usuario local con una contraseña, los errores se detuvieron.

Su experiencia puede ser diferente.


0

En mi caso el error fue el siguiente:

exim paniclog on my-host has non-zero size

socket bind() to port 25 for address ::1 failed: cannot assign requested address: daemon abandoned

Mi solución fue eliminar el paniclogarchivo y dpkg reconfigure exim4-configeliminarlo ::1de las IP para vincularlo.

Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.