¿Cómo inicio un servidor MySQL en Windows?


9

He instalado un servidor MySQL en mi computadora y cuando lo instalé por primera vez, se ejecutó automáticamente. Ahora he reiniciado mi computadora, ya no se está ejecutando. ¿Qué archivo necesito ejecutar para que vuelva a funcionar?

He intentado ejecutar MySQL 5.6 Command Line Client y mysqld.exedesde el Program Files/MySQL/MySQLServer/bindirectorio, y no he tenido suerte.

Al ejecutar mysqld.exe, aparece el siguiente error:

2013-10-28 18:52:12 4788 [ERROR] InnoDB: .\ibdata1 can't be opened in read-write mode
2013-10-28 18:52:12 4788 [ERROR] InnoDB: The system tablespace must be writable!
2013-10-28 18:52:12 4788 [ERROR] Plugin 'InnoDB' init function returned error.
2013-10-28 18:52:12 4788 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2013-10-28 18:52:12 4788 [ERROR] Unknown/unsupported storage engine: InnoDB
2013-10-28 18:52:12 4788 [ERROR] Aborting`

Naturalmente, intenté ejecutarlo como administrador, y obtuve esto:

C:\Windows\system32>"C:\Program Files\MySQL\MySQL Server 5.6\bin\mysqld.exe"
2013-10-28 19:24:30 0 [Warning] TIMESTAMP with implicit DEFAULT value is depreca
ted. Please use --explicit_defaults_for_timestamp server option (see documentati
on for more details).

2
Así es como me siento ahora: i.imgur.com/xVyoSl.jpg
— Shaun Wild

1
instale mysql workbench e intente acceder desde allí
— Shekhar

Respuestas:


3

Asegúrese de que mysqld.exeesté marcado debajo de la Startuppestaña cuando vaya a ejecutar y escriba msconfig. Además, lo mismo ocurre Services, busque los servicios de MySQL allí, haga clic con el botón derecho> propiedades y asegúrese de que los tipos de inicio estén seleccionados como automáticos.


¿Cómo ejecuto el servidor?
— Shaun Wild

¿Has intentado ejecutarlo manualmente? ¿Simplemente iniciando mysqld.exe? Solo puedo verificar los servicios exactos mañana en el trabajo, no los saco de mi cabeza.
— Rudolph el

Sí, por favor revisa mi pregunta.
— Shaun Wild

2
Configuré el servicio como automático y reinicié mi computadora, trabajo hecho. ¡Gracias!
— Shaun Wild

9

Si instaló MySQL utilizando el instalador MSI, debe configurarse como un servicio.

Puede abrir el servicio de dos maneras.

MÉTODO # 1: Acceda al servicio instalado

  • Abra el ícono Servicios en el Panel de control
  • Desplácese alfabéticamente al servicio MySQL
  • Haga clic derecho en el servicio
  • Haga clic en Iniciar servicio

MÉTODO # 2: Ejecución de línea de comando

  • Abrir ventana de DOS
  • Desde el indicador C: ejecute esto: net start mysqlo 'net start mysql57'. El nombre correcto puede variar en su sistema

Si obtienes este error

C:\Windows\system32>net start mysql
System error 5 has occurred.

Access is denied.

C:\Windows\system32>

entonces no ejecutó la ventana de DOS como administrador. Intente nuevamente como administrador. Debería ver:

C:\Windows\system32>net start mysql
The MySQL service is starting..
The MySQL service was started successfully.


C:\Windows\system32>

¡¡¡Darle una oportunidad!!!


Gracias, pero pensé que es la mejor práctica / medida de seguridad ejecutar mysql server como no administrador, dígame por favor
— user10089632

-1

Si está utilizando wamp en Windows, puede iniciar mysql desde la línea de comandos:

cd \wamp64
cd bin
cd mysql
dir
[check the version no of mysql]
cd mysql<version no>
mysql.exe -u root

Esto supone que ha instalado wamp en la raíz


Eso es para conectarse a un servidor, no para iniciar el servidor.
— lpacheco

-2

Para iniciar manualmente el servicio mysql, debe ejecutar el ejecutable mysqld. Abra el símbolo del sistema y escriba:

shell> "C:\Program Files\MySQL\MySQLServer\bin\mysqld"

Si mysqld no se inicia, verifique el registro de errores. El registro de errores se encuentra en C: \ Archivos de programa \ MySQL \ MySQLServer \ data. Es el archivo con un sufijo de .err. También puede intentar iniciar el servidor como mysqld --console; en este caso, puede obtener información útil en la pantalla que puede ayudar a resolver el problema.

La última opción es iniciar mysqld con las opciones --standalone y --debug. En este caso, mysqld escribe un archivo de registro C: \ mysqld.trace que debe contener la razón por la cual mysqld no se inicia.


Revise mi pregunta nuevamente por favor.
— Shaun Wild

¿Estás usando la PC con una cuenta de administrador? Parece que no tiene permiso suficiente para leer / escribir en esa carpeta.
— enry

Sí, soy administrador.
— Shaun Wild

He actualizado mi pregunta con lo que sucedió. /
— Shaun Wild

Debe usar la opción de línea de comando --explicit_defaults_for_timestamp, en el símbolo del sistema: mysqld --explicit_defaults_for_timestamp = 1
— enry
Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.