No se puede reiniciar el demonio SSH después de cambiar sshd_config al puerto 2222


1

He estado buscando y no pude encontrar una solución al problema que estoy teniendo. Estoy corriendo Ubuntu 16.04 LTSy seguí las instrucciones en la página de Ubuntu para cambiar el puerto SSH 2222actualizando el sshd_configarchivo.

# What ports, IPs and protocols we listen for
Port 2222

sudo systemctl restart sshd.serviceSin embargo, cuando ejecuto el comando , solo aparece el siguiente error:

Job for ssh.service failed because the control process exited with error code. See "systemctl status ssh.service" and "journalctl -xe" for details.

Luego ejecuté el comando systemctl status ssh.servicey obtuve

● ssh.service - OpenBSD Secure Shell server
   Loaded: loaded (/lib/systemd/system/ssh.service; enabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2016-09-07 23:24:04 EDT; 1min 28s ago
  Process: 16813 ExecStart=/usr/sbin/sshd -D $SSHD_OPTS (code=exited, status=255)
 Main PID: 16813 (code=exited, status=255)

Sep 07 23:24:04 sys-0 systemd[1]: Starting OpenBSD Secure Shell server...
Sep 07 23:24:04 sys-0 systemd[1]: ssh.service: Main process exited, code=exited, status=255/n/a
Sep 07 23:24:04 sys-0 systemd[1]: Failed to start OpenBSD Secure Shell server.
Sep 07 23:24:04 sys-0 systemd[1]: ssh.service: Unit entered failed state.
Sep 07 23:24:04 sys-0 systemd[1]: ssh.service: Failed with result 'exit-code'.

¿Qué significa el error y cómo puedo solucionarlo?


3
Lo más probable es que haya cometido un simple error en su sshd_config. ¿Qué pasa si vuelves a poner el original?
— techraf

sudo sshd -vvvf /etc/ssh/sshd_configdebería darte una pista de lo que está mal
— Paul

Cuando devuelvo el original, funciona como de costumbre. Sin embargo, el puerto 2222funcionó para mí hoy haciendo exactamente lo mismo que hice anoche. Muy raro.
— FullStack

@techraf borré el otro. Nunca estoy seguro de qué SE es mejor para este tipo de preguntas
— FullStack

@Paul en openssh-server 1: 7.4p1-10 + deb9u2 en Debian 9 que obtengo unknown option -- v.
— Pablo Bianchi

Respuestas:


2

¿Está ejecutando en un sistema que utiliza SELinux? Podría ser que esto está negando el enlace del puerto; intente agregar una nueva regla.

semanage port -a -t ssh_port_t -p tcp 2222

no, no estoy corriendo SELinux, pero de alguna manera esta mañana funcionó lo mismo. Muchas gracias por su aporte
— FullStack

Gracias esto me ayudó!
— DomenicDatti

2

Como dijo @techraf, lo más probable es que haya cometido un simple error en su /etc/ssh/sshd_config. Prueba el modo de prueba sshd :

$ sudo sshd -t
/etc/ssh/sshd_config: line 1: Bad configuration option: sds

Desde la página del manual :

  • -t Modo de prueba . Solo verifique la validez del archivo de configuración y la cordura de las claves. Esto es útil para actualizar sshd de manera confiable ya que las opciones de configuración pueden cambiar.
  • -T Modo de prueba extendido . Verifique la validez del archivo de configuración, envíe la configuración efectiva a stdout y luego salga. Opcionalmente, las reglas de coincidencia pueden aplicarse especificando los parámetros de conexión utilizando una o más opciones -C.

0
cd /etc/ssh/sshd_config

o

sudo vim /etc/ssh/sshd_config

y

comentar esta línea Subsystem sftp /usr/lib/openssh/sftp-server. Me refiero a cambiar esta línea Subsystem sftp /usr/lib/openssh/sftp-servercon#Subsystem sftp /usr/lib/openssh/sftp-server


Sigue siendo el mismo error, nada ha cambiado
— Sayali
Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.