Cómo montar Time Capsule desde Raspberry Pi


12

Hay una cápsula de tiempo de 2 TB en mi red doméstica (IP 192.168.0.1). ¿Cómo puedo montar el disco de Time Capsule desde mi Raspberry Pi, automáticamente después de reiniciar?

Respuestas:


14

Ponlo en fstab.

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user=timecapsuleUsername,pass=timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

El cifs-utilspaquete requerido ya debe estar provisto en raspbian.

Por supuesto, cambie timecapsuleUsername y timecapsuleUserPassword. El uid = 1000 establece el propietario de los archivos montados en el usuario pi. Si está utilizando otro usuario, compruebe que sea uid con id -u username. Compruebe si la carpeta "Datos" es adecuada para usted: enumere los recursos emitiendo un comando smbclient -Uusername -I ip-address -L.


Me sale este error al intentar montar: mount error(115): Operation now in progress. Sin embargo, puedo acceder al recurso compartido con smbclient. ¿Algunas ideas?
— Arne

Lo tengo: primero lo intenté con el .localnombre en lugar de la IP, no parece funcionar de manera confiable. En segundo lugar, necesitaba agregar sec=ntlma las opciones. ¡Ahora funciona!
— Arne

Si se selecciona la opción Disks Secure SharedDiscos With a disk password, entonces user=se ignorará el parámetro independientemente de lo que esté configurado
— Hengjie

Acabo de probar esto en una Time Capsule que ejecuta el último firmware (7.6.7) en un Pi que ejecuta OSMC. La clave es sec=ntlmy puedo confirmar que esto funciona con discos asegurados con una contraseña de dispositivo, así como una contraseña de disco.
— Gary Gale

5

Tengo que agregar sec = ntlm a las opciones, el comando completo es:

sudo su
mkdir /mnt/timecapsule
echo "//timeCapsuleIp/Data /mnt/timecapsule cifs user= timecapsuleUsername,pass= timecapsuleUserPassword,rw,uid=1000,iocharset=utf8,sec=ntlm 0 0" >> /etc/fstab

Luego, ejecuta este comando:

mount -a

No deberías obtener ningún error.


4

Actualización para usuarios de Raspberry Stretch v9. Tenga en cuenta la adición de vers = 1.0

//IPofTimeCapsule/PathWithinYourTimeCapsule /mnt/TimeCapsule cifs username=insert,password=insert,rw,uid=1000,iocharset=utf8,sec=ntlm,vers=1.0 0 0

¿Qué quieres decir con la línea que comienza //IPofTimeCapsule?
— Ingo

Lo siento si no estaba claro, me refería a la dirección IP de TimeCapsule. Por ejemplo, la línea podría leer ... //192.168.1.11/Data / mnt / TimeCapsule cifs username = bsmith, password = batman, rw, uid = 1000, iocharset = utf8, sec = ntlm, vers = 1.0 0 0
— ddavila

1

Para mí, cuando utilizo una contraseña de disco en la cápsula del tiempo, solo funcionó cuando agregué uid = 504 (que es el ID de usuario utilizado en el Macintosh principalmente usando la cápsula del tiempo, no el UID utilizado en la frambuesa). Cuando no puse uid = 504, recibí "error de montaje (16): dispositivo o recurso ocupado" de la cápsula del tiempo.

Al usar nuestro sitio, usted reconoce que ha leído y comprende nuestra Política de Cookies y Política de Privacidad.
Licensed under cc by-sa 3.0 with attribution required.