Usar un VRF es como usar un enrutador separado. Si tiene la misma IP WAN para ambos VRF, debe configurarla dos veces en ambas interfaces WAN. Sin embargo, si solo usa una interfaz WAN, tendrá que dividir esta interfaz mediante enlaces troncales (usando VLAN) o subinterfaces.
ex:
interface FastEthernet0.5
encapsulation dot1Q 5
ip address 1.1.1.1 255.255.255.252
Tenga en cuenta que no usamos el reenvío de vrf ip, estamos usando el vrf predeterminado
interface FastEthernet0.10
ip vrf forwarding wanconnection:1
encapsulation dot1Q 10
ip address 1.1.1.1 255.255.255.252 (<== this can be another IP if you prefer to divide it with 2 different IP's)
La conexión entonces es como sigue:
- su enrutador (vrf normal) => conexión wan => vpn utilizado para la etiqueta dot1Q 5
- su enrutador (wanconnection: 1 vrf) => wan connection => vpn utilizado para la etiqueta dot1Q 10
si desea hacer esto sin etiquetar y solo tiene 2 interfaces físicas, es la misma implementación:
interface FastEthernet0
ip address 1.1.1.1 255.255.255.252
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 1.1.1.1 255.255.255.252
Cualquier otra interfaz necesaria en la vrf específica "wanconnection: 1" debe agregarse de la misma manera:
ip vrf forwarding wanconnection:1
ex:
interface FastEthernet4
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
haciendo un vrf: http://www.cisco.com/en/US/docs/switches/lan/catalyst4500/12.2/15.02SG/configuration/guide/vrf.html
ip vrf wanconnection:1
rd 65000:1
El comando rd 100: 1 explica: Crea una tabla VRF especificando un distintivo de ruta. Ingrese un número AS y un número arbitrario (xxx: y) o una dirección IP y un número arbitrario (ABCD: y).
para la parte de enrutamiento:
ip route 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 1.1.1.2
Si solo tiene una conexión WAN sin etiquetado habilitado, puede usar el enrutamiento entre Vrf: http://packetlife.net/blog/2010/mar/29/inter-vrf-routing-vrf-lite/
ex:
ip vrf wanconnection:1
rd 65000:1
route-target export 65000:2
route-target import 65000:99
ip vrf wanconnection:2
rd 65000:2
route-target export 65000:1
route-target import 65000:99
ip vrf shared:1
rd 65000:99
route-target export 65000:99
route-target import 65000:1
route-target import 65000:2
interface FastEthernet0
ip vrf forwarding shared:1
ip address 1.1.1.1 255.255.255.252
interface loopback1
ip vrf forwarding shared:1
ip address 2.2.2.2 255.255.255.255
ip route vrf shared:1 0.0.0.0 0.0.0.0 1.1.1.2
ip route vrf wanconnection:1 0.0.0.0 0.0.0.0 2.2.2.2
ip route vrf wanconnection:2 0.0.0.0 0.0.0.0 2.2.2.2
interface FastEthernet1
ip vrf forwarding wanconnection:1
ip address 10.0.0.1 255.255.255.0
description "LAN interface vrf 1"
interface FastEthernet2
ip vrf forwarding wanconnection:2
ip address 10.0.2.1 255.255.255.0
description "LAN interface vrf 2"
aquí FastEthernet1 usará la ruta predeterminada para vrf wanconnection: 1 y FastEthernet2 usará la ruta predeterminada para vrf wanconnection: 2 (proporcionada por los comandos "ip route").